Installation

Installation

Server Requirements

  • PHP >= 5.6.4
  • OCI8 PHP Extension

Installing Laravel OCI8

Laravel OCI8 can be installed with Composer. More details about this package in Composer can be found here.

Run the following command in your project to get the latest version of the package:

composer require yajra/laravel-oci8

Configuration

You can use Laravel OCI8 with Laravel as well as Lumen.

With Laravel

Open the file config/app.php and then add following service provider.

'providers' => [
    // ...
    Yajra\Oci8\Oci8ServiceProvider::class,
],

Note: This step is (optional) for the publication of configuration files.

After completing the step above, use the following command to publish configuration settings:

php artisan vendor:publish --tag=oracle

With Lumen

Open the file bootstrap/app.php and then add following service provider. This step is required.

$app->register(Yajra\Oci8\Oci8ServiceProvider::class);

You should also uncomment the $app->withFacades() and $app->withEloquent() call in your bootstrap/app.php file.

// ...

$app->withFacades();

$app->withEloquent();

// ...